aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-03-08 04:44:43 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-03-08 04:44:43 +0100
commit3ca82ea98fc46e3365c514aa3398f54df91bf329 (patch)
tree0b12c50c17ecdb46d9f201218bbcd4d128665bfc /Makefile.am
parent99661b01b0dbf6a0ccb34574f599992e714ac726 (diff)
downloadblogc-3ca82ea98fc46e3365c514aa3398f54df91bf329.tar.gz
blogc-3ca82ea98fc46e3365c514aa3398f54df91bf329.tar.bz2
blogc-3ca82ea98fc46e3365c514aa3398f54df91bf329.zip
build: added make rule to build srpm
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cb91a50..1c5388d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -314,6 +314,16 @@ TESTS = \
$(check_PROGRAMS)
+## Helpers: dist-srpm
+if USE_RPMBUILD
+dist-srpm: blogc.spec dist-xz
+ $(RPMBUILD) \
+ --define "_srcrpmdir $(top_builddir)" \
+ --define "_sourcedir $(top_builddir)" \
+ -bs blogc.spec
+endif
+
+
## Helpers: git-version-gen
$(top_srcdir)/.version: