aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-04-27 03:22:31 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-04-27 03:22:31 +0200
commit6f975248895d0300c6fd8783b1138bdd4be00bcc (patch)
tree79a3f2d17000b6429685ba39bd47412bca1bcf21 /Makefile.am
parent9699bf0ce6b34c0d05c509925f3367f2200caad5 (diff)
downloadblogc-6f975248895d0300c6fd8783b1138bdd4be00bcc.tar.gz
blogc-6f975248895d0300c6fd8783b1138bdd4be00bcc.tar.bz2
blogc-6f975248895d0300c6fd8783b1138bdd4be00bcc.zip
blogc-git-receiver: import external tool to blogc repository
still in the effort to reduce maintenance work, I'm importing blogc-git-receiver tool to the main blogc repository. the tool is build by default, if needed headers are found. that means that it will probably only be built for posix-compliant operating systems.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am55
1 files changed, 52 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8237508..934e1cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-tests \
--enable-ronn \
--disable-valgrind \
+ --enable-git-receiver \
$(NULL)
@@ -43,6 +44,7 @@ noinst_HEADERS = \
noinst_LTLIBRARIES = \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
noinst_PROGRAMS = \
@@ -52,6 +54,12 @@ bin_PROGRAMS = \
blogc \
$(NULL)
+if BUILD_GIT_RECEIVER
+bin_PROGRAMS += \
+ blogc-git-receiver \
+ $(NULL)
+endif
+
check_PROGRAMS = \
$(NULL)
@@ -65,7 +73,6 @@ libblogc_la_SOURCES = \
src/renderer.c \
src/source-parser.c \
src/template-parser.c \
- src/utils.c \
$(NULL)
libblogc_la_CFLAGS = \
@@ -78,8 +85,18 @@ libblogc_la_LIBADD = \
$(NULL)
+libblogc_utils_la_SOURCES = \
+ src/utils.c \
+ $(NULL)
+
+libblogc_utils_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ -I$(top_srcdir)/src \
+ $(NULL)
+
+
blogc_SOURCES = \
- src/main.c \
+ src/blogc.c \
$(NULL)
blogc_CFLAGS = \
@@ -89,9 +106,26 @@ blogc_CFLAGS = \
blogc_LDADD = \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
+if BUILD_GIT_RECEIVER
+blogc_git_receiver_SOURCES = \
+ src/blogc-git-receiver.c \
+ $(NULL)
+
+blogc_git_receiver_CFLAGS = \
+ $(AM_CFLAGS) \
+ -I$(top_srcdir)/src \
+ $(NULL)
+
+blogc_git_receiver_LDADD = \
+ libblogc_utils.la \
+ $(NULL)
+endif
+
+
## Build rules: man pages
EXTRA_DIST += \
@@ -107,6 +141,14 @@ dist_man_MANS = \
blogc-template.7 \
$(NULL)
+if BUILD_GIT_RECEIVER
+EXTRA_DIST += \
+ $(NULL)
+
+dist_man_MANS += \
+ $(NULL)
+endif
+
MAINTAINERCLEANFILES += \
$(dist_man_MANS) \
$(NULL)
@@ -181,6 +223,7 @@ tests_check_error_LDFLAGS = \
tests_check_error_LDADD = \
$(CMOCKA_LIBS) \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
tests_check_loader_SOURCES = \
@@ -200,6 +243,7 @@ tests_check_loader_LDFLAGS = \
tests_check_loader_LDADD = \
$(CMOCKA_LIBS) \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
tests_check_content_parser_SOURCES = \
@@ -217,6 +261,7 @@ tests_check_content_parser_LDFLAGS = \
tests_check_content_parser_LDADD = \
$(CMOCKA_LIBS) \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
tests_check_datetime_parser_SOURCES = \
@@ -234,6 +279,7 @@ tests_check_datetime_parser_LDFLAGS = \
tests_check_datetime_parser_LDADD = \
$(CMOCKA_LIBS) \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
tests_check_renderer_SOURCES = \
@@ -251,6 +297,7 @@ tests_check_renderer_LDFLAGS = \
tests_check_renderer_LDADD = \
$(CMOCKA_LIBS) \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
tests_check_source_parser_SOURCES = \
@@ -268,6 +315,7 @@ tests_check_source_parser_LDFLAGS = \
tests_check_source_parser_LDADD = \
$(CMOCKA_LIBS) \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
tests_check_template_parser_SOURCES = \
@@ -285,6 +333,7 @@ tests_check_template_parser_LDFLAGS = \
tests_check_template_parser_LDADD = \
$(CMOCKA_LIBS) \
libblogc.la \
+ libblogc_utils.la \
$(NULL)
tests_check_utils_SOURCES = \
@@ -301,7 +350,7 @@ tests_check_utils_LDFLAGS = \
tests_check_utils_LDADD = \
$(CMOCKA_LIBS) \
- libblogc.la \
+ libblogc_utils.la \
$(NULL)
endif