aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-17 01:47:41 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-17 01:47:41 -0300
commit047e4e3753c597628024847a524d44ca67fa1382 (patch)
tree8c0d63ecd8d395815a4eee155c2ce6283e0e7fab /Makefile.am
parentf5da9cc42acc79d7dda78e57fab8a1b8d7aa6a7d (diff)
downloadblogc-047e4e3753c597628024847a524d44ca67fa1382.tar.gz
blogc-047e4e3753c597628024847a524d44ca67fa1382.tar.bz2
blogc-047e4e3753c597628024847a524d44ca67fa1382.zip
replaced leg-based parser with handmade parser for source files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index b1548bc..3138d25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,7 +14,6 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
EXTRA_DIST = \
autogen.sh \
README.md \
- src/source-grammar.leg \
src/template-grammar.leg \
$(NULL)
@@ -22,7 +21,8 @@ CLEANFILES = \
$(NULL)
noinst_HEADERS = \
- src/source-grammar.h \
+ src/output.h \
+ src/source-parser.h \
src/template-grammar.h \
src/utils/utils.h \
$(NULL)
@@ -43,7 +43,8 @@ check_PROGRAMS = \
libblogc_la_SOURCES = \
- src/source-grammar.c \
+ src/output.c \
+ src/source-parser.c \
src/template-grammar.c \
src/utils/slist.c \
src/utils/strings.c \
@@ -92,24 +93,24 @@ endif
if USE_CMOCKA
check_PROGRAMS += \
- tests/check_source_grammar \
+ tests/check_source_parser \
tests/check_template_grammar \
tests/check_utils \
$(NULL)
-tests_check_source_grammar_SOURCES = \
- tests/check_source_grammar.c \
+tests_check_source_parser_SOURCES = \
+ tests/check_source_parser.c \
$(NULL)
-tests_check_source_grammar_CFLAGS = \
+tests_check_source_parser_CFLAGS = \
$(CMOCKA_CFLAGS) \
$(NULL)
-tests_check_source_grammar_LDFLAGS = \
+tests_check_source_parser_LDFLAGS = \
-no-install \
$(NULL)
-tests_check_source_grammar_LDADD = \
+tests_check_source_parser_LDADD = \
$(CMOCKA_LIBS) \
libblogc.la \
$(NULL)