aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-02-26 01:04:32 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-02-26 01:04:32 +0100
commit3b0f9293a3432023cdca91df01418347d9781ffa (patch)
treee872df7080979732ddf3efbdaabc8a4bdafd0653 /Makefile.am
parentbdff66b0013165c3ef7eff644fb276235f3dd082 (diff)
downloadblogc-3b0f9293a3432023cdca91df01418347d9781ffa.tar.gz
blogc-3b0f9293a3432023cdca91df01418347d9781ffa.tar.bz2
blogc-3b0f9293a3432023cdca91df01418347d9781ffa.zip
build: replace src/utils with squareball
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am46
1 files changed, 23 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index 832b19c..cb91a50 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,16 @@
## Autotools settings
+if INTERNAL_SQUAREBALL
+SUBDIRS = squareball
+endif
+
ACLOCAL_AMFLAGS = -I m4
AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-tests \
--enable-ronn \
--disable-valgrind \
+ --with-squareball=internal \
$(NULL)
@@ -39,7 +44,6 @@ noinst_HEADERS = \
src/renderer.h \
src/source-parser.h \
src/template-parser.h \
- src/utils/utils.h \
$(NULL)
noinst_LTLIBRARIES = \
@@ -66,19 +70,17 @@ libblogc_la_SOURCES = \
src/renderer.c \
src/source-parser.c \
src/template-parser.c \
- src/utils/mem.c \
- src/utils/slist.c \
- src/utils/strings.c \
- src/utils/trie.c \
$(NULL)
libblogc_la_CFLAGS = \
$(AM_CFLAGS) \
-I$(top_srcdir)/src \
+ $(SQUAREBALL_CFLAGS) \
$(NULL)
libblogc_la_LIBADD = \
$(LIBM) \
+ $(SQUAREBALL_LIBS) \
$(NULL)
@@ -89,10 +91,12 @@ blogc_SOURCES = \
blogc_CFLAGS = \
$(AM_CFLAGS) \
-I$(top_srcdir)/src \
+ $(SQUAREBALL_CFLAGS) \
$(NULL)
blogc_LDADD = \
libblogc.la \
+ $(SQUAREBALL_LIBS) \
$(NULL)
@@ -167,7 +171,6 @@ check_PROGRAMS += \
tests/check_renderer \
tests/check_source_parser \
tests/check_template_parser \
- tests/check_utils \
$(NULL)
tests_check_error_SOURCES = \
@@ -175,6 +178,7 @@ tests_check_error_SOURCES = \
$(NULL)
tests_check_error_CFLAGS = \
+ $(SQUAREBALL_CFLAGS) \
$(CMOCKA_CFLAGS) \
$(NULL)
@@ -183,6 +187,7 @@ tests_check_error_LDFLAGS = \
$(NULL)
tests_check_error_LDADD = \
+ $(SQUAREBALL_LIBS) \
$(CMOCKA_LIBS) \
libblogc.la \
$(NULL)
@@ -192,6 +197,7 @@ tests_check_loader_SOURCES = \
$(NULL)
tests_check_loader_CFLAGS = \
+ $(SQUAREBALL_CFLAGS) \
$(CMOCKA_CFLAGS) \
$(NULL)
@@ -202,6 +208,7 @@ tests_check_loader_LDFLAGS = \
$(NULL)
tests_check_loader_LDADD = \
+ $(SQUAREBALL_LIBS) \
$(CMOCKA_LIBS) \
libblogc.la \
$(NULL)
@@ -211,6 +218,7 @@ tests_check_content_parser_SOURCES = \
$(NULL)
tests_check_content_parser_CFLAGS = \
+ $(SQUAREBALL_CFLAGS) \
$(CMOCKA_CFLAGS) \
$(NULL)
@@ -219,6 +227,7 @@ tests_check_content_parser_LDFLAGS = \
$(NULL)
tests_check_content_parser_LDADD = \
+ $(SQUAREBALL_LIBS) \
$(CMOCKA_LIBS) \
libblogc.la \
$(NULL)
@@ -228,6 +237,7 @@ tests_check_datetime_parser_SOURCES = \
$(NULL)
tests_check_datetime_parser_CFLAGS = \
+ $(SQUAREBALL_CFLAGS) \
$(CMOCKA_CFLAGS) \
$(NULL)
@@ -236,6 +246,7 @@ tests_check_datetime_parser_LDFLAGS = \
$(NULL)
tests_check_datetime_parser_LDADD = \
+ $(SQUAREBALL_LIBS) \
$(CMOCKA_LIBS) \
libblogc.la \
$(NULL)
@@ -245,6 +256,7 @@ tests_check_renderer_SOURCES = \
$(NULL)
tests_check_renderer_CFLAGS = \
+ $(SQUAREBALL_CFLAGS) \
$(CMOCKA_CFLAGS) \
$(NULL)
@@ -253,6 +265,7 @@ tests_check_renderer_LDFLAGS = \
$(NULL)
tests_check_renderer_LDADD = \
+ $(SQUAREBALL_LIBS) \
$(CMOCKA_LIBS) \
libblogc.la \
$(NULL)
@@ -262,6 +275,7 @@ tests_check_source_parser_SOURCES = \
$(NULL)
tests_check_source_parser_CFLAGS = \
+ $(SQUAREBALL_CFLAGS) \
$(CMOCKA_CFLAGS) \
$(NULL)
@@ -270,6 +284,7 @@ tests_check_source_parser_LDFLAGS = \
$(NULL)
tests_check_source_parser_LDADD = \
+ $(SQUAREBALL_LIBS) \
$(CMOCKA_LIBS) \
libblogc.la \
$(NULL)
@@ -279,6 +294,7 @@ tests_check_template_parser_SOURCES = \
$(NULL)
tests_check_template_parser_CFLAGS = \
+ $(SQUAREBALL_CFLAGS) \
$(CMOCKA_CFLAGS) \
$(NULL)
@@ -287,23 +303,7 @@ tests_check_template_parser_LDFLAGS = \
$(NULL)
tests_check_template_parser_LDADD = \
- $(CMOCKA_LIBS) \
- libblogc.la \
- $(NULL)
-
-tests_check_utils_SOURCES = \
- tests/check_utils.c \
- $(NULL)
-
-tests_check_utils_CFLAGS = \
- $(CMOCKA_CFLAGS) \
- $(NULL)
-
-tests_check_utils_LDFLAGS = \
- -no-install \
- $(NULL)
-
-tests_check_utils_LDADD = \
+ $(SQUAREBALL_LIBS) \
$(CMOCKA_LIBS) \
libblogc.la \
$(NULL)