aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-01-31 15:58:59 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-01-31 15:58:59 +0100
commitb83328369a82aa35fec714d7edd703e2243cc40e (patch)
tree145b0d3856adde9cb015ddeed20223108d9d799d /Makefile.am
parent95e1696e37cf1bae3239acf41d351951364f11ef (diff)
downloadblogc-b83328369a82aa35fec714d7edd703e2243cc40e.tar.gz
blogc-b83328369a82aa35fec714d7edd703e2243cc40e.tar.bz2
blogc-b83328369a82aa35fec714d7edd703e2243cc40e.zip
Revert "Revert "build: added git-version-gen support""
This reverts commit 8e01ccec4837027a12a4bfc6a54e3c09440169a9.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e143b0b..7b52fa0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,6 +13,8 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
EXTRA_DIST = \
build-aux/build-windows.sh \
+ build-aux/git-version-gen \
+ $(top_srcdir)/.version \
autogen.sh \
LICENSE \
README.md \
@@ -24,6 +26,10 @@ CLEANFILES = \
MAINTAINERCLEANFILES = \
$(NULL)
+BUILT_SOURCES = \
+ $(top_srcdir)/.version \
+ $(NULL)
+
noinst_HEADERS = \
src/content-parser.h \
src/datetime-parser.h \
@@ -308,6 +314,15 @@ TESTS = \
$(check_PROGRAMS)
+## Helpers: git-version-gen
+
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
+
+
## Helpers: Valgrind runner
if USE_VALGRIND