aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-04-27 03:51:42 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-04-27 03:51:42 +0200
commitc4b294c890c28004d33f650b7af5064c4099f608 (patch)
tree5ea09b812092670243cc186e6233c8483acac7eb /Makefile.am
parent6f975248895d0300c6fd8783b1138bdd4be00bcc (diff)
downloadblogc-c4b294c890c28004d33f650b7af5064c4099f608.tar.gz
blogc-c4b294c890c28004d33f650b7af5064c4099f608.tar.bz2
blogc-c4b294c890c28004d33f650b7af5064c4099f608.zip
blogc-runserver: import external tool to blogc repository
still in the effort to reduce maintenance work, I'm importing blogc-runserver tool to the main blogc repository. the tool is build by default, if needed headers and libraries are found.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 934e1cc..7e42b6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-ronn \
--disable-valgrind \
--enable-git-receiver \
+ --enable-runserver \
$(NULL)
@@ -60,6 +61,12 @@ bin_PROGRAMS += \
$(NULL)
endif
+if BUILD_RUNSERVER
+bin_PROGRAMS += \
+ blogc-runserver \
+ $(NULL)
+endif
+
check_PROGRAMS = \
$(NULL)
@@ -126,6 +133,26 @@ blogc_git_receiver_LDADD = \
endif
+if BUILD_RUNSERVER
+blogc_runserver_SOURCES = \
+ src/blogc-runserver.c \
+ $(NULL)
+
+blogc_runserver_CFLAGS = \
+ $(AM_CFLAGS) \
+ -I$(top_srcdir)/src \
+ $(LIBEVENT_CFLAGS) \
+ $(SQUAREBALL_CFLAGS) \
+ $(NULL)
+
+blogc_runserver_LDADD = \
+ $(LIBEVENT_LIBS) \
+ $(MAGIC_LIBS) \
+ libblogc_utils.la \
+ $(NULL)
+endif
+
+
## Build rules: man pages
EXTRA_DIST += \
@@ -149,6 +176,14 @@ dist_man_MANS += \
$(NULL)
endif
+if BUILD_RUNSERVER
+EXTRA_DIST += \
+ $(NULL)
+
+dist_man_MANS += \
+ $(NULL)
+endif
+
MAINTAINERCLEANFILES += \
$(dist_man_MANS) \
$(NULL)