aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 14:36:19 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 14:36:19 -0300
commitb81e0c2b1c70badf4131cf8a587a06e1c31df1f5 (patch)
tree1b6099808b8d762120fb5742c4edff6e5adfc198 /Makefile.am
parentd301477f1aba66d5f0996da7a610e703d34837c1 (diff)
downloadblogc-b81e0c2b1c70badf4131cf8a587a06e1c31df1f5.tar.gz
blogc-b81e0c2b1c70badf4131cf8a587a06e1c31df1f5.tar.bz2
blogc-b81e0c2b1c70badf4131cf8a587a06e1c31df1f5.zip
loader: added compiler-defined variables
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a4fb15..a6539a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -83,11 +83,29 @@ blogc_LDADD = \
if USE_CMOCKA
check_PROGRAMS += \
+ tests/check_loader \
tests/check_source_parser \
tests/check_template_parser \
tests/check_utils \
$(NULL)
+tests_check_loader_SOURCES = \
+ tests/check_loader.c \
+ $(NULL)
+
+tests_check_loader_CFLAGS = \
+ $(CMOCKA_CFLAGS) \
+ $(NULL)
+
+tests_check_loader_LDFLAGS = \
+ -no-install \
+ $(NULL)
+
+tests_check_loader_LDADD = \
+ $(CMOCKA_LIBS) \
+ libblogc.la \
+ $(NULL)
+
tests_check_source_parser_SOURCES = \
tests/check_source_parser.c \
$(NULL)