aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-12-07 02:25:05 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-12-07 02:25:05 +0100
commitdbc036c94e38286fcbc439c176dd7a7ffd6bbbd6 (patch)
tree937112dd6831901e39ef4c17e07f78fbdbbc19f5 /Makefile.am
parent7f531a7bf4582c57c2d465ce96353a87adc0ac95 (diff)
downloadblogc-dbc036c94e38286fcbc439c176dd7a7ffd6bbbd6.tar.gz
blogc-dbc036c94e38286fcbc439c176dd7a7ffd6bbbd6.tar.bz2
blogc-dbc036c94e38286fcbc439c176dd7a7ffd6bbbd6.zip
github-lambda: initial implementation of AWS Lambda function
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a759fc..cc5a672 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,6 +23,7 @@ EXTRA_DIST = \
blogc.spec \
LICENSE \
README.md \
+ src/blogc-github-lambda/lambda_function.py
$(NULL)
CLEANFILES = \
@@ -667,6 +668,8 @@ TESTS = \
CLEANFILES += \
$(check_SCRIPTS) \
+ src/blogc-github-lambda/README \
+ src/blogc-github-lambda/blogc \
$(NULL)
@@ -698,3 +701,26 @@ valgrind: all
VALGRIND=$(VALGRIND) \
$(BASH) -e $(top_srcdir)/build-aux/valgrind.sh"
endif
+
+
+## Helpers: blogc-github-lambda
+
+$(top_builddir)/blogc-github-lambda-$(VERSION).zip: $(top_builddir)/blogc $(top_srcdir)/LICENSE $(top_srcdir)/src/blogc-github-lambda/lambda_function.py
+ -rm -f $(top_builddir)/blogc-github-lambda-$(VERSION).zip
+ $(MKDIR_P) $(top_builddir)/src/blogc-github-lambda
+ $(INSTALL) -m 644 \
+ $(top_srcdir)/LICENSE \
+ $(top_builddir)/src/blogc-github-lambda/
+ $(INSTALL) -m 644 -C \
+ $(top_srcdir)/src/blogc-github-lambda/lambda_function.py \
+ $(top_builddir)/src/blogc-github-lambda/
+ $(INSTALL) -m 755 \
+ $(top_builddir)/blogc \
+ $(top_builddir)/src/blogc-github-lambda/blogc
+ cd $(top_builddir)/src/blogc-github-lambda && \
+ zip -rq $(abs_top_builddir)/blogc-github-lambda-$(VERSION).zip LICENSE blogc lambda_function.py
+
+blogc-github-lambda: $(top_builddir)/blogc-github-lambda-$(VERSION).zip
+
+
+.PHONY: dist-srpm valgrind blogc-github-lambda