aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2019-02-25 22:43:51 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2020-01-12 12:37:11 +0100
commit7870e88f0653e6ac93c1f2e123aa9826778be376 (patch)
tree98d9c0840bf809ab5be36539680d0997762f3bb4 /Makefile.am
parenta45e7255cb89d76c4836e1cac073c2f941529e70 (diff)
downloadblogc-7870e88f0653e6ac93c1f2e123aa9826778be376.tar.gz
blogc-7870e88f0653e6ac93c1f2e123aa9826778be376.tar.bz2
blogc-7870e88f0653e6ac93c1f2e123aa9826778be376.zip
make: implemented optional sass support using libsassfeature/sass
pending: - tests for sass support - build tests on ci with and without libsass - documentation - support sass options in blogcfile
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 040f291..5fae160 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,7 @@ noinst_HEADERS = \
src/blogc-make/httpd.h \
src/blogc-make/reloader.h \
src/blogc-make/rules.h \
+ src/blogc-make/sass.h \
src/blogc-make/settings.h \
src/blogc-make/utils.h \
src/blogc-runserver/httpd.h \
@@ -235,6 +236,16 @@ blogc_make_LDADD = \
libblogc_make.la \
libblogc_common.la \
$(NULL)
+
+if USE_LIBSASS
+blogc_make_CFLAGS += \
+ $(LIBSASS_CFLAGS) \
+ $(NULL)
+
+blogc_make_LDADD += \
+ $(LIBSASS_LIBS) \
+ $(NULL)
+endif
endif
if BUILD_MAKE_LIB
@@ -259,6 +270,20 @@ libblogc_make_la_LIBADD = \
$(PTHREAD_LIBS) \
libblogc_common.la \
$(NULL)
+
+if USE_LIBSASS
+libblogc_make_la_SOURCES += \
+ src/blogc-make/sass.c \
+ $(NULL)
+
+libblogc_make_la_CFLAGS += \
+ $(LIBSASS_CFLAGS) \
+ $(NULL)
+
+libblogc_make_la_LIBADD += \
+ $(LIBSASS_LIBS) \
+ $(NULL)
+endif
endif