aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 16:45:20 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 16:45:20 -0300
commit329ef39c0fe382498dde48b5822b041a3804f618 (patch)
treec03815c65098339ee161139634d66a1cb827b959 /Makefile.am
parentd5ae7feec228e88f2c728a1fec2d331c88789a1b (diff)
downloadblogc-329ef39c0fe382498dde48b5822b041a3804f618.tar.gz
blogc-329ef39c0fe382498dde48b5822b041a3804f618.tar.bz2
blogc-329ef39c0fe382498dde48b5822b041a3804f618.zip
error: added tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 71747dc..0988b5f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,12 +81,30 @@ blogc_LDADD = \
if USE_CMOCKA
check_PROGRAMS += \
+ tests/check_error \
tests/check_loader \
tests/check_source_parser \
tests/check_template_parser \
tests/check_utils \
$(NULL)
+tests_check_error_SOURCES = \
+ tests/check_error.c \
+ $(NULL)
+
+tests_check_error_CFLAGS = \
+ $(CMOCKA_CFLAGS) \
+ $(NULL)
+
+tests_check_error_LDFLAGS = \
+ -no-install \
+ $(NULL)
+
+tests_check_error_LDADD = \
+ $(CMOCKA_LIBS) \
+ libblogc.la \
+ $(NULL)
+
tests_check_loader_SOURCES = \
tests/check_loader.c \
$(NULL)