aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 19:16:24 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 19:16:24 -0300
commit37444105873802ac3fb70ac0cd81269361e5e559 (patch)
tree5f23efd8779537bd185a21f05f15a12eb82af434 /Makefile.am
parent01e9b5c0191762b75175f6eabfb9915f9899fc15 (diff)
downloadblogc-37444105873802ac3fb70ac0cd81269361e5e559.tar.gz
blogc-37444105873802ac3fb70ac0cd81269361e5e559.tar.bz2
blogc-37444105873802ac3fb70ac0cd81269361e5e559.zip
build: fix valgrind support
no need to call tests with libtool, because they are linked with -no-install, disabling libtool wrappers. also, removed glib-related environment variables, that aren't needed here.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 7 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c56a55..b0fa633 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -184,16 +184,12 @@ TESTS = \
if USE_VALGRIND
valgrind: all
$(MAKE) check TESTS_ENVIRONMENT=" \
- G_SLICE=always-malloc \
- G_DEBUG=gc-friendly \
- $(LIBTOOL) \
- --mode=execute \
- $(VALGRIND) \
- --tool=memcheck \
- --leak-check=full \
- --leak-resolution=high \
- --num-callers=20 \
- --error-exitcode=1 \
- --show-possibly-lost=no"
+ $(VALGRIND) \
+ --tool=memcheck \
+ --leak-check=full \
+ --leak-resolution=high \
+ --num-callers=20 \
+ --error-exitcode=1 \
+ --show-possibly-lost=no"
endif