aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-12-23 19:53:04 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-12-23 21:02:33 +0100
commit950e6c9148eca244a89d18a21d4ae4e5c3d1c646 (patch)
tree8664cf3156b92e4083e0680a0a1f21e20a2b22c9 /Makefile.am
parentb75293a565b6f319435516fe253bd61688ba3a1f (diff)
downloadblogc-950e6c9148eca244a89d18a21d4ae4e5c3d1c646.tar.gz
blogc-950e6c9148eca244a89d18a21d4ae4e5c3d1c646.tar.bz2
blogc-950e6c9148eca244a89d18a21d4ae4e5c3d1c646.zip
build: removing src/utils and replacing with squareball
squareball is a new general purpose library for C99, based on the code removed from src/utils
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am94
1 files changed, 70 insertions, 24 deletions
diff --git a/Makefile.am b/Makefile.am
index 78738cc..3f70901 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,15 +6,65 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-tests \
--enable-ronn \
--disable-valgrind \
+ --with-squareball=internal \
$(NULL)
+## squareball stuff
+
+SQUAREBALL_EXTRA_DIST_ = \
+ squareball/LICENSE \
+ squareball/README.md \
+ $(NULL)
+
+if USE_SYSTEM_SQUAREBALL
+
+SQUAREBALL_HEADERS_ =
+
+SQUAREBALL_SOURCES_ =
+
+SQUAREBALL_CFLAGS_ = \
+ $(SQUAREBALL_CFLAGS) \
+ $(NULL)
+
+SQUAREBALL_LIBS_ = \
+ $(SQUAREBALL_LIBS) \
+ $(NULL)
+
+else
+
+SQUAREBALL_HEADERS_ = \
+ squareball/src/squareball.h \
+ squareball/src/squareball/sb-mem.h \
+ squareball/src/squareball/sb-slist.h \
+ squareball/src/squareball/sb-string.h \
+ squareball/src/squareball/sb-trie.h \
+ squareball/src/squareball/sb-trie-private.h \
+ $(NULL)
+
+SQUAREBALL_SOURCES_ = \
+ squareball/src/sb-mem.c \
+ squareball/src/sb-slist.c \
+ squareball/src/sb-string.c \
+ squareball/src/sb-trie.c \
+ $(NULL)
+
+SQUAREBALL_CFLAGS_ = \
+ -I$(top_srcdir)/squareball/src \
+ $(NULL)
+
+SQUAREBALL_LIBS_ =
+
+endif
+
+
## File listings
EXTRA_DIST = \
autogen.sh \
LICENSE \
README.md \
+ $(SQUAREBALL_EXTRA_DIST_)
$(NULL)
CLEANFILES = \
@@ -32,7 +82,7 @@ noinst_HEADERS = \
src/renderer.h \
src/source-parser.h \
src/template-parser.h \
- src/utils/utils.h \
+ $(SQUAREBALL_HEADERS_)
$(NULL)
noinst_LTLIBRARIES = \
@@ -59,22 +109,20 @@ libblogc_la_SOURCES = \
src/renderer.c \
src/source-parser.c \
src/template-parser.c \
- src/utils/mem.c \
- src/utils/slist.c \
- src/utils/strings.c \
- src/utils/trie.c \
+ $(SQUAREBALL_SOURCES_) \
$(NULL)
libblogc_la_CFLAGS = \
$(AM_CFLAGS) \
-I$(top_srcdir)/src \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
libblogc_la_LIBADD = \
$(LIBM) \
+ $(SQUAREBALL_LIBS_) \
$(NULL)
-
blogc_SOURCES = \
src/main.c \
$(NULL)
@@ -82,10 +130,12 @@ blogc_SOURCES = \
blogc_CFLAGS = \
$(AM_CFLAGS) \
-I$(top_srcdir)/src \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
blogc_LDADD = \
libblogc.la \
+ $(SQUAREBALL_LIBS_) \
$(NULL)
@@ -160,7 +210,6 @@ check_PROGRAMS += \
tests/check_renderer \
tests/check_source_parser \
tests/check_template_parser \
- tests/check_utils \
$(NULL)
tests_check_error_SOURCES = \
@@ -169,6 +218,7 @@ tests_check_error_SOURCES = \
tests_check_error_CFLAGS = \
$(CMOCKA_CFLAGS) \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
tests_check_error_LDFLAGS = \
@@ -177,6 +227,7 @@ tests_check_error_LDFLAGS = \
tests_check_error_LDADD = \
$(CMOCKA_LIBS) \
+ $(SQUAREBALL_LIBS_) \
libblogc.la \
$(NULL)
@@ -186,6 +237,7 @@ tests_check_loader_SOURCES = \
tests_check_loader_CFLAGS = \
$(CMOCKA_CFLAGS) \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
tests_check_loader_LDFLAGS = \
@@ -196,6 +248,7 @@ tests_check_loader_LDFLAGS = \
tests_check_loader_LDADD = \
$(CMOCKA_LIBS) \
+ $(SQUAREBALL_LIBS_) \
libblogc.la \
$(NULL)
@@ -205,6 +258,7 @@ tests_check_content_parser_SOURCES = \
tests_check_content_parser_CFLAGS = \
$(CMOCKA_CFLAGS) \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
tests_check_content_parser_LDFLAGS = \
@@ -213,6 +267,7 @@ tests_check_content_parser_LDFLAGS = \
tests_check_content_parser_LDADD = \
$(CMOCKA_LIBS) \
+ $(SQUAREBALL_LIBS_) \
libblogc.la \
$(NULL)
@@ -222,6 +277,7 @@ tests_check_datetime_parser_SOURCES = \
tests_check_datetime_parser_CFLAGS = \
$(CMOCKA_CFLAGS) \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
tests_check_datetime_parser_LDFLAGS = \
@@ -230,6 +286,7 @@ tests_check_datetime_parser_LDFLAGS = \
tests_check_datetime_parser_LDADD = \
$(CMOCKA_LIBS) \
+ $(SQUAREBALL_LIBS_) \
libblogc.la \
$(NULL)
@@ -239,6 +296,7 @@ tests_check_renderer_SOURCES = \
tests_check_renderer_CFLAGS = \
$(CMOCKA_CFLAGS) \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
tests_check_renderer_LDFLAGS = \
@@ -247,6 +305,7 @@ tests_check_renderer_LDFLAGS = \
tests_check_renderer_LDADD = \
$(CMOCKA_LIBS) \
+ $(SQUAREBALL_LIBS_) \
libblogc.la \
$(NULL)
@@ -256,6 +315,7 @@ tests_check_source_parser_SOURCES = \
tests_check_source_parser_CFLAGS = \
$(CMOCKA_CFLAGS) \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
tests_check_source_parser_LDFLAGS = \
@@ -264,6 +324,7 @@ tests_check_source_parser_LDFLAGS = \
tests_check_source_parser_LDADD = \
$(CMOCKA_LIBS) \
+ $(SQUAREBALL_LIBS_) \
libblogc.la \
$(NULL)
@@ -273,6 +334,7 @@ tests_check_template_parser_SOURCES = \
tests_check_template_parser_CFLAGS = \
$(CMOCKA_CFLAGS) \
+ $(SQUAREBALL_CFLAGS_) \
$(NULL)
tests_check_template_parser_LDFLAGS = \
@@ -281,23 +343,7 @@ tests_check_template_parser_LDFLAGS = \
tests_check_template_parser_LDADD = \
$(CMOCKA_LIBS) \
- libblogc.la \
- $(NULL)
-
-tests_check_utils_SOURCES = \
- tests/check_utils.c \
- $(NULL)
-
-tests_check_utils_CFLAGS = \
- $(CMOCKA_CFLAGS) \
- $(NULL)
-
-tests_check_utils_LDFLAGS = \
- -no-install \
- $(NULL)
-
-tests_check_utils_LDADD = \
- $(CMOCKA_LIBS) \
+ $(SQUAREBALL_LIBS_) \
libblogc.la \
$(NULL)