aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 15:15:37 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 15:15:37 -0300
commita90e21e40723a63a5727906d82cf33e111c787c5 (patch)
tree8f7c37fed6704d5f6a0e22ddee2846cb0a456542 /Makefile.am
parent54fa2d51eb9096e265af18ad2f916eedfc018858 (diff)
downloadblogc-a90e21e40723a63a5727906d82cf33e111c787c5.tar.gz
blogc-a90e21e40723a63a5727906d82cf33e111c787c5.tar.bz2
blogc-a90e21e40723a63a5727906d82cf33e111c787c5.zip
build: fixed valgrind support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 2 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index a6539a7..a934945 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -163,7 +163,7 @@ TESTS = \
$(check_PROGRAMS)
-## Helpers: Valgrind runners
+## Helpers: Valgrind runner
if USE_VALGRIND
valgrind: all
@@ -177,26 +177,5 @@ valgrind: all
--leak-check=full \
--leak-resolution=high \
--num-callers=20 \
+ --error-exitcode=1 \
--show-possibly-lost=no"
-
-valgrind-ci: all clean-local
- $(MAKE) check TESTS_ENVIRONMENT=" \
- G_SLICE=always-malloc \
- G_DEBUG=gc-friendly \
- $(LIBTOOL) \
- --mode=execute \
- $(VALGRIND) \
- --tool=memcheck \
- --xml=yes \
- --xml-file=valgrind-%p.xml \
- --leak-check=full \
- --leak-resolution=high \
- --num-callers=20 \
- --show-possibly-lost=no"
-endif
-
-
-# Helpers: Cleanup of helper files
-
-clean-local:
- -rm -rf $(top_builddir)/valgrind-*.xml