aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2017-02-11 18:51:12 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2017-02-11 18:51:12 +0100
commitcbeba5720d1b98cd7db013038b741b1a6ac9e48c (patch)
tree01c84556d6a799847e287c4f1eb73cabc3d06d38 /Makefile.am
parentee6b177bc1cbc55472c85497e5043163d89ff814 (diff)
downloadblogc-cbeba5720d1b98cd7db013038b741b1a6ac9e48c.tar.gz
blogc-cbeba5720d1b98cd7db013038b741b1a6ac9e48c.tar.bz2
blogc-cbeba5720d1b98cd7db013038b741b1a6ac9e48c.zip
Revert "make: do not require pthreads"
This reverts commit dd0ff8219b749f89ae66261830d10f1c27940b19.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8514766..d1317d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,9 +215,11 @@ blogc_make_SOURCES = \
blogc_make_CFLAGS = \
$(AM_CFLAGS) \
+ $(PTHREAD_CFLAGS) \
$(NULL)
blogc_make_LDADD = \
+ $(PTHREAD_LIBS) \
libblogc_make.la \
libblogc_common.la \
$(NULL)
@@ -235,10 +237,12 @@ libblogc_make_la_SOURCES = \
libblogc_make_la_CFLAGS = \
$(AM_CFLAGS) \
+ $(PTHREAD_CFLAGS) \
$(NULL)
libblogc_make_la_LIBADD = \
$(LIBM) \
+ $(PTHREAD_LIBS) \
libblogc_common.la \
$(NULL)
endif