aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2019-02-23 23:48:32 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2019-02-23 23:48:32 +0100
commit2ae2d648ab0bd5340ca1342c97d704b2d4ce948c (patch)
tree8edea5ed6859668fdf9ca12a86b5ca4adcd9424f /Makefile.am
parent83952ad3d567fc9a307d9f330033f4036618f1f8 (diff)
downloadblogc-2ae2d648ab0bd5340ca1342c97d704b2d4ce948c.tar.gz
blogc-2ae2d648ab0bd5340ca1342c97d704b2d4ce948c.tar.bz2
blogc-2ae2d648ab0bd5340ca1342c97d704b2d4ce948c.zip
blogc: sysinfo: simplified username impl. fixed tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index f2a8ffa..b136f9f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -534,19 +534,14 @@ tests_blogc_check_sysinfo_CFLAGS = \
tests_blogc_check_sysinfo_LDFLAGS = \
-no-install \
-Wl,--wrap=bc_file_get_contents \
- -Wl,--wrap=gethostname \
+ -Wl,--wrap=getenv \
$(NULL)
if HAVE_UNISTD_H
-if HAVE_SYS_TYPES_H
-if HAVE_PWD_H
tests_blogc_check_sysinfo_LDFLAGS += \
- -Wl,--wrap=geteuid \
- -Wl,--wrap=getpwuid \
+ -Wl,--wrap=gethostname \
$(NULL)
endif
-endif
-endif
if HAVE_TIME_H
tests_blogc_check_sysinfo_LDFLAGS += \