aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-10 02:13:47 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-10 02:13:47 +0200
commit3cd3dcb5bb3b0481812ddd3ff8dc182bdb20be23 (patch)
treed99f57f85d2472caf334a4b96fbebd95cee873f7 /Makefile.am
parent62f999141701ba915a035a11cbac7fc7ddb08f31 (diff)
downloadblogc-3cd3dcb5bb3b0481812ddd3ff8dc182bdb20be23.tar.gz
blogc-3cd3dcb5bb3b0481812ddd3ff8dc182bdb20be23.tar.bz2
blogc-3cd3dcb5bb3b0481812ddd3ff8dc182bdb20be23.zip
git-receiver: added support to get mirror url from config file
this commit also includes some "integration test" in shell script
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am44
1 files changed, 35 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 31c1dca..54c71bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,6 +15,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
EXTRA_DIST = \
build-aux/git-version-gen \
+ build-aux/valgrind.sh \
$(top_srcdir)/.version \
autogen.sh \
LICENSE \
@@ -90,6 +91,9 @@ endif
check_PROGRAMS = \
$(NULL)
+dist_check_SCRIPTS = \
+ $(NULL)
+
libblogc_la_SOURCES = \
src/blogc/content-parser.c \
@@ -314,6 +318,12 @@ endif
## Build rules: tests
+if BUILD_GIT_RECEIVER
+dist_check_SCRIPTS += \
+ tests/blogc-git-receiver/check_post_receive.sh \
+ $(NULL)
+endif
+
if USE_CMOCKA
check_PROGRAMS += \
@@ -573,6 +583,7 @@ endif
if BUILD_GIT_RECEIVER
check_PROGRAMS += \
tests/blogc-git-receiver/check_pre_receive_parser \
+ tests/blogc-git-receiver/check_post_receive \
tests/blogc-git-receiver/check_shell_command_parser \
$(NULL)
@@ -594,6 +605,25 @@ tests_blogc_git_receiver_check_pre_receive_parser_LDADD = \
libblogc_common.la \
$(NULL)
+tests_blogc_git_receiver_check_post_receive_SOURCES = \
+ tests/blogc-git-receiver/check_post_receive.c \
+ $(NULL)
+
+tests_blogc_git_receiver_check_post_receive_CFLAGS = \
+ $(CMOCKA_CFLAGS) \
+ $(NULL)
+
+tests_blogc_git_receiver_check_post_receive_LDFLAGS = \
+ -no-install \
+ -Wl,--wrap=realpath \
+ $(NULL)
+
+tests_blogc_git_receiver_check_post_receive_LDADD = \
+ $(CMOCKA_LIBS) \
+ libblogc_git_receiver.la \
+ libblogc_common.la \
+ $(NULL)
+
tests_blogc_git_receiver_check_shell_command_parser_SOURCES = \
tests/blogc-git-receiver/check_shell_command_parser.c \
$(NULL)
@@ -616,7 +646,9 @@ endif
endif
TESTS = \
- $(check_PROGRAMS)
+ $(check_PROGRAMS) \
+ $(dist_check_SCRIPTS) \
+ $(NULL)
## Helpers: dist-srpm
@@ -644,12 +676,6 @@ dist-hook:
if USE_VALGRIND
valgrind: all
$(MAKE) check TESTS_ENVIRONMENT=" \
- $(VALGRIND) \
- --tool=memcheck \
- --leak-check=full \
- --leak-resolution=high \
- --num-callers=20 \
- --error-exitcode=1 \
- --show-possibly-lost=no"
-
+ VALGRIND=$(VALGRIND) \
+ $(top_srcdir)/build-aux/valgrind.sh"
endif