aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-02-26 01:04:32 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-02-26 01:04:32 +0100
commit3b0f9293a3432023cdca91df01418347d9781ffa (patch)
treee872df7080979732ddf3efbdaabc8a4bdafd0653 /configure.ac
parentbdff66b0013165c3ef7eff644fb276235f3dd082 (diff)
downloadblogc-3b0f9293a3432023cdca91df01418347d9781ffa.tar.gz
blogc-3b0f9293a3432023cdca91df01418347d9781ffa.tar.bz2
blogc-3b0f9293a3432023cdca91df01418347d9781ffa.zip
build: replace src/utils with squareball
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdb7c1e..ea03fd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,10 +99,35 @@ AC_CHECK_HEADERS([sys/types.h sys/stat.h time.h])
LT_LIB_M
+AC_ARG_WITH([squareball], [AS_HELP_STRING([--with-squareball=@<:@internal/system@:>@],
+ [whether to use library squareball from system [default=internal]])])
+AS_IF([test "x$with_squareball" = "xsystem"], [
+ PKG_CHECK_MODULES([SQUAREBALL], [squareball], [
+ SQUAREBALL="system"
+ ], [
+ AC_MSG_ERROR([library squareball requested from system but not found])
+ ])
+], [
+ SQUAREBALL="internal"
+ SQUAREBALL_CFLAGS='-I$(top_srcdir)/squareball/src'
+ SQUAREBALL_LIBS='$(top_builddir)/squareball/libsquareball.la'
+ AC_SUBST(SQUAREBALL_LIBS)
+ AC_SUBST(SQUAREBALL_CFLAGS)
+ ac_configure_args_pre="$ac_configure_args"
+ ac_configure_args_post="$ac_configure_args --enable-bundleme"
+ ac_configure_args="$ac_configure_args_post"
+ AC_CONFIG_COMMANDS_PRE([ac_configure_args="$ac_configure_args_pre"])
+ AC_CONFIG_COMMANDS_POST([ac_configure_args="$ac_configure_args_post"])
+ AC_CONFIG_SUBDIRS([squareball])
+ ac_configure_args="$ac_configure_args_pre"
+])
+AM_CONDITIONAL(INTERNAL_SQUAREBALL, [test "x$with_squareball" != "xsystem"])
+
AC_CONFIG_FILES([
Makefile
blogc.spec
])
+
AC_OUTPUT
AS_ECHO("
@@ -116,6 +141,7 @@ AS_ECHO("
cflags: ${CFLAGS}
ldflags: ${LDFLAGS}
+ squareball: ${SQUAREBALL}
tests: ${TESTS}
ronn: ${RONN}