aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-08-14 12:38:03 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-08-14 12:38:03 -0300
commitdbcfaf413330e71dbf329f9b07884b275221088c (patch)
tree415aaccc116349e05e7d99f41afbfcc7754fa188 /configure.ac
parent451752b5436f661879b8a3e9d1770d1e1239a257 (diff)
downloadblogc-dbcfaf413330e71dbf329f9b07884b275221088c.tar.gz
blogc-dbcfaf413330e71dbf329f9b07884b275221088c.tar.bz2
blogc-dbcfaf413330e71dbf329f9b07884b275221088c.zip
build: call PKG_PROG_PKG_CONFIG globally
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 94e8620..adedf65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,8 @@ AS_IF([test "x$ac_cv_prog_cc_c99" = "xno"], [
AC_MSG_ERROR([no C99 compiler found, blogc requires a C99 compiler.])
])
+PKG_PROG_PKG_CONFIG
+
AC_ARG_ENABLE([ronn], AS_HELP_STRING([--disable-ronn],
[ignore presence of ronn and disable man pages generation]))
AS_IF([test "x$enable_ronn" != "xno"], [
@@ -60,7 +62,6 @@ TESTS="disabled"
AC_ARG_ENABLE([tests], AS_HELP_STRING([--disable-tests],
[disable unit tests, ignoring presence of cmocka]))
AS_IF([test "x$enable_tests" != "xno"], [
- PKG_PROG_PKG_CONFIG
PKG_CHECK_MODULES([CMOCKA], [cmocka], [
AC_MSG_CHECKING([whether the linker supports -wrap])
save_LDFLAGS="$LDFLAGS"