aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-13 01:50:32 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-13 01:50:32 +0200
commit836ea885b2fc62cc7b483149937b91c93815e8ae (patch)
treee67b03c4b9f7fad977447031c365124aad30cf14 /configure.ac
parent108e30d1964ae4739c722cede7ed7f26b226735e (diff)
downloadblogc-836ea885b2fc62cc7b483149937b91c93815e8ae.tar.gz
blogc-836ea885b2fc62cc7b483149937b91c93815e8ae.tar.bz2
blogc-836ea885b2fc62cc7b483149937b91c93815e8ae.zip
build: disable all tests if some dep not found
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 21 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 9926099..081dfbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,16 +156,32 @@ AS_IF([test "x$enable_tests" != "xno"], [
])
])
-AS_IF([test "x$enable_tests" = "xyes"], [
- AS_IF([test "x$have_cmocka" = "xyes"],, [
+AS_IF([test "x$have_cmocka" = "xyes"],, [
+ have_tests=no
+ TESTS="disabled"
+ AS_IF([test "x$enable_tests" = "xyes"], [
AC_MSG_ERROR([tests requested but cmocka not found])
+ ], [
+ AC_MSG_WARN([cmocka not found, install it to run tests])
])
- AS_IF([test "x$have_blogc_deps" = "xyes"],, [
+])
+AS_IF([test "x$have_blogc_deps" = "xyes"],, [
+ have_tests=no
+ TESTS="disabled"
+ AS_IF([test "x$enable_tests" = "xyes"], [
AC_MSG_ERROR([tests requested but bash and/or tee not found])
+ ], [
+ AC_MSG_WARN([bash and/or tee not found, install it to run tests])
])
- AS_IF([test "x$have_bgr_deps" = "xyes"], , [
- AS_IF([test "x$have_git_receiver" = "xyes"], [
+])
+AS_IF([test "x$have_bgr_deps" = "xyes"], , [
+ AS_IF([test "x$have_git_receiver" = "xyes"], [
+ have_tests=no
+ TESTS="disabled"
+ AS_IF([test "x$enable_tests" = "xyes"], [
AC_MSG_ERROR([tests requested for blogc-git-receiver but git and/or tar not found])
+ ], [
+ AC_MSG_WARN([git and/or tar not found, install it to run blogc-git-receiver tests])
])
])
])