aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2019-02-25 22:43:51 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2020-01-12 12:37:11 +0100
commit7870e88f0653e6ac93c1f2e123aa9826778be376 (patch)
tree98d9c0840bf809ab5be36539680d0997762f3bb4 /configure.ac
parenta45e7255cb89d76c4836e1cac073c2f941529e70 (diff)
downloadblogc-7870e88f0653e6ac93c1f2e123aa9826778be376.tar.gz
blogc-7870e88f0653e6ac93c1f2e123aa9826778be376.tar.bz2
blogc-7870e88f0653e6ac93c1f2e123aa9826778be376.zip
make: implemented optional sass support using libsassfeature/sass
pending: - tests for sass support - build tests on ci with and without libsass - documentation - support sass options in blogcfile
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 880acf4..afe2cab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,6 +102,8 @@ AC_ARG_ENABLE([make-embedded], AS_HELP_STRING([--enable-make-embedded],
[build blogc-make tool embedded on blogc binary]))
AC_ARG_ENABLE([make], AS_HELP_STRING([--enable-make],
[build blogc-make tool]))
+AC_ARG_WITH([libsass], AS_HELP_STRING([--without-libsass],
+ [disable blogc-make dependency on libsass]))
AS_IF([test "x$enable_make" = "xyes" -o "x$enable_make_embedded" = "xyes"], [
AC_CHECK_HEADERS([dirent.h fcntl.h libgen.h sys/stat.h sys/wait.h time.h unistd.h],, [
AC_MSG_ERROR([blogc-make tool requested but required headers not found])
@@ -118,10 +120,20 @@ AS_IF([test "x$enable_make" = "xyes" -o "x$enable_make_embedded" = "xyes"], [
MAKE_="enabled"
have_make=yes
])
+ AS_IF([test "x$with_libsass" != "xno"], [
+ PKG_CHECK_MODULES([LIBSASS], [libsass], [
+ MAKE_="${MAKE_} (with libsass)"
+ have_libsass=yes
+ AC_DEFINE([USE_LIBSASS], [], [Build blogc-make with libsass support])
+ ], [
+ have_libsass=no
+ ])
+ ])
])
AM_CONDITIONAL([BUILD_MAKE], [test "x$have_make" = "xyes"])
AM_CONDITIONAL([BUILD_MAKE_LIB], [test "x$have_make_lib" = "xyes"])
AM_CONDITIONAL([BUILD_MAKE_EMBEDDED], [test "x$have_make_embedded" = "xyes"])
+AM_CONDITIONAL([USE_LIBSASS], [test "x$have_libsass" = "xyes"])
RUNSERVER="disabled"
AC_ARG_ENABLE([runserver], AS_HELP_STRING([--enable-runserver],