aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-11 23:05:22 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-11 23:05:22 +0200
commitbbe4028f33626c7928c36d78f176b21bbeaa7655 (patch)
tree479ed5014ee49d447648816f89b390d8c1aa276e /configure.ac
parente4fefe520d58547935b2c4147dd6b712b9047c1e (diff)
downloadblogc-bbe4028f33626c7928c36d78f176b21bbeaa7655.tar.gz
blogc-bbe4028f33626c7928c36d78f176b21bbeaa7655.tar.bz2
blogc-bbe4028f33626c7928c36d78f176b21bbeaa7655.zip
build: tee should not be git-receiver dep, will be used by more tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 14 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 2886527..8d29465 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,28 +141,32 @@ AS_IF([test "x$enable_tests" != "xno"], [
have_cmocka=no
])
AC_PATH_PROG([git], [git])
- AC_PATH_PROG([tee], [tee])
AC_PATH_PROG([tar], [tar])
- AS_IF([test "x$ac_cv_path_git" = "x" -o "x$ac_cv_path_tee" = "x" -o "x$ac_cv_path_tar" = "x"], [
+ AS_IF([test "x$ac_cv_path_git" = "x" -o "x$ac_cv_path_tar" = "x"], [
have_bgr_deps=no
], [
have_bgr_deps=yes
])
+ AC_PATH_PROG([tee], [tee])
+ AS_IF([test "x$ac_cv_path_tee" = "x"], [
+ have_tee=no
+ ], [
+ have_tee=yes
+ ])
], [
have_tests=no
])
AS_IF([test "x$have_tests" = "xyes"], [
- AS_IF([test "x$have_cmocka" = "xyes"], [
- TESTS="${TESTS} +cmocka"
- ], [
- AC_MSG_ERROR([unit tests requested but cmocka not found])
+ AS_IF([test "x$have_cmocka" = "xyes"],, [
+ AC_MSG_ERROR([tests requested but cmocka not found])
])
- AS_IF([test "x$have_bgr_deps" = "xyes"], [
- TESTS="${TESTS} +blogc-git-receiver"
- ], [
+ AS_IF([test "x$have_tee" = "xyes"],, [
+ AC_MSG_ERROR([tests requested but tee not found])
+ ])
+ AS_IF([test "x$have_bgr_deps" = "xyes"], , [
AS_IF([test "x$have_git_receiver" = "xyes"], [
- AC_MSG_ERROR([unit tests requested for blogc-git-receiver but git, tar and tee not found])
+ AC_MSG_ERROR([tests requested for blogc-git-receiver but git and/or tar not found])
])
])
])