aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-15 17:44:39 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-15 17:44:39 +0200
commit921620e3df696442b688024c499541862bcd03eb (patch)
tree6d54f6de2b2e541e19f57237bdc875b0d850b739 /configure.ac
parent0196af8ee525ec6a4cae707aec46b73a1e56a461 (diff)
downloadblogc-921620e3df696442b688024c499541862bcd03eb.tar.gz
blogc-921620e3df696442b688024c499541862bcd03eb.tar.bz2
blogc-921620e3df696442b688024c499541862bcd03eb.zip
blogc: added some "integration" tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 081dfbc..2ec6dcd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,8 +146,9 @@ AS_IF([test "x$enable_tests" != "xno"], [
have_bgr_deps=yes
])
AC_PATH_PROG([bash], [bash])
+ AC_PATH_PROG([diff], [diff])
AC_PATH_PROG([tee], [tee])
- AS_IF([test "x$ac_cv_path_bash" = "x" -o "x$ac_cv_path_tee" = "x"], [
+ AS_IF([test "x$ac_cv_path_bash" = "x" -o "x$ac_cv_path_diff" = "x" -o "x$ac_cv_path_tee" = "x"], [
have_blogc_deps=no
], [
have_blogc_deps=yes
@@ -169,9 +170,9 @@ AS_IF([test "x$have_blogc_deps" = "xyes"],, [
have_tests=no
TESTS="disabled"
AS_IF([test "x$enable_tests" = "xyes"], [
- AC_MSG_ERROR([tests requested but bash and/or tee not found])
+ AC_MSG_ERROR([tests requested but bash, diff and/or tee not found])
], [
- AC_MSG_WARN([bash and/or tee not found, install it to run tests])
+ AC_MSG_WARN([bash, diff and/or tee not found, install it to run tests])
])
])
AS_IF([test "x$have_bgr_deps" = "xyes"], , [
@@ -199,6 +200,8 @@ AC_CONFIG_FILES([
Makefile
blogc.spec
])
+AC_CONFIG_FILES([tests/blogc/check_blogc.sh],
+ [chmod +x tests/blogc/check_blogc.sh])
AC_CONFIG_FILES([tests/blogc-git-receiver/check_pre_receive.sh],
[chmod +x tests/blogc-git-receiver/check_pre_receive.sh])
AC_CONFIG_FILES([tests/blogc-git-receiver/check_post_receive.sh],