aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-04-27 03:22:31 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-04-27 03:22:31 +0200
commit6f975248895d0300c6fd8783b1138bdd4be00bcc (patch)
tree79a3f2d17000b6429685ba39bd47412bca1bcf21 /configure.ac
parent9699bf0ce6b34c0d05c509925f3367f2200caad5 (diff)
downloadblogc-6f975248895d0300c6fd8783b1138bdd4be00bcc.tar.gz
blogc-6f975248895d0300c6fd8783b1138bdd4be00bcc.tar.bz2
blogc-6f975248895d0300c6fd8783b1138bdd4be00bcc.zip
blogc-git-receiver: import external tool to blogc repository
still in the effort to reduce maintenance work, I'm importing blogc-git-receiver tool to the main blogc repository. the tool is build by default, if needed headers are found. that means that it will probably only be built for posix-compliant operating systems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 31 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 1e7366e..858db59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,24 @@ AS_IF([test "x$have_cmocka" = "xyes"], , [
])
AM_CONDITIONAL([USE_CMOCKA], [test "x$have_cmocka" = "xyes"])
+GIT_RECEIVER="disabled"
+AC_ARG_ENABLE([git-receiver], AS_HELP_STRING([--disable-git-receiver],
+ [disable blogc-git-receiver build]))
+AS_IF([test "x$enable_git_receiver" != "xno"], [
+ AC_CHECK_HEADERS([sys/types.h sys/stat.h time.h libgen.h unistd.h errno.h dirent.h], [
+ GIT_RECEIVER="enabled"
+ have_git_receiver=yes
+ ], [
+ have_git_receiver=no
+ ])
+])
+AS_IF([test "x$have_git_receiver" = "xyes"], , [
+ AS_IF([test "x$enable_git_receiver" = "xyes"], [
+ AC_MSG_ERROR([blogc-git-receiver requested but required headers not found])
+ ])
+])
+AM_CONDITIONAL([BUILD_GIT_RECEIVER], [test "x$have_git_receiver" = "xyes"])
+
AC_CHECK_HEADERS([sys/types.h sys/stat.h time.h])
LT_LIB_M
@@ -131,19 +149,21 @@ AC_CONFIG_FILES([
AC_OUTPUT
AS_ECHO("
- ==== ${PACKAGE_STRING} ====
+ ====== ${PACKAGE_STRING} ======
+
+ prefix: ${prefix}
+ exec_prefix: ${exec_prefix}
+ bindir: ${bindir}
- prefix: ${prefix}
- exec_prefix: ${exec_prefix}
- bindir: ${bindir}
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ ldflags: ${LDFLAGS}
- compiler: ${CC}
- cflags: ${CFLAGS}
- ldflags: ${LDFLAGS}
+ blogc-git-receiver: ${GIT_RECEIVER}
- tests: ${TESTS}
+ tests: ${TESTS}
- ronn: ${RONN}
- valgrind: ${VALGRIND}
- rpmbuild: ${RPMBUILD}
+ ronn: ${RONN}
+ valgrind: ${VALGRIND}
+ rpmbuild: ${RPMBUILD}
")