aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-16 13:26:25 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2016-10-16 13:26:25 +0200
commit57a56f04f68f5f731baa14f4c1cd679ff25b1e92 (patch)
treee823a4a7b41c83ca92937571a2564c53bb013cdc /configure.ac
parent9367adcb7006acc4783ec8d453e73ec14938a92d (diff)
downloadblogc-57a56f04f68f5f731baa14f4c1cd679ff25b1e92.tar.gz
blogc-57a56f04f68f5f731baa14f4c1cd679ff25b1e92.tar.bz2
blogc-57a56f04f68f5f731baa14f4c1cd679ff25b1e92.zip
build: added missing dependencies
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 16 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 3442771..b7abf15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,13 +149,27 @@ AS_IF([test "x$enable_tests" != "xno"], [
])
AC_PATH_PROG([git], [git])
+ AC_PATH_PROG([make], [make])
AC_PATH_PROG([tar], [tar])
- AS_IF([test "x$ac_cv_path_git" = "x" -o "x$ac_cv_path_tar" = "x"], [
+ AS_IF([test "x$ac_cv_path_git" = "x" -o "x$ac_cv_path_make" = "x" -o "x$ac_cv_path_tar" = "x"], [
have_bgr_deps=no
+ AS_IF([test "x$have_git_receiver" = "xyes"], [
+ have_tests=no
+ TESTS="disabled"
+ AS_IF([test "x$enable_tests" = "xyes"], [
+ AC_MSG_ERROR([tests requested for blogc-git-receiver but git and/or tar not found])
+ ], [
+ AC_MSG_WARN([git and/or tar not found, install it to run blogc-git-receiver tests])
+ ])
+ ])
], [
have_bgr_deps=yes
])
- AS_IF([test "x$have_blogc_deps" = "xyes"],, [
+
+ AC_PATH_PROG([bash], [bash])
+ AC_PATH_PROG([diff], [diff])
+ AC_PATH_PROG([tee], [tee])
+ AS_IF([test "x$ac_cv_path_bash" = "x" -o "x$ac_cv_path_diff" = "x" -o "x$ac_cv_path_tee" = "x"], [
have_tests=no
TESTS="disabled"
AS_IF([test "x$enable_tests" = "xyes"], [
@@ -163,29 +177,10 @@ AS_IF([test "x$enable_tests" != "xno"], [
], [
AC_MSG_WARN([bash, diff and/or tee not found, install it to run tests])
])
- ])
-
- AC_PATH_PROG([bash], [bash])
- AC_PATH_PROG([diff], [diff])
- AC_PATH_PROG([tee], [tee])
- AS_IF([test "x$ac_cv_path_bash" = "x" -o "x$ac_cv_path_diff" = "x" -o "x$ac_cv_path_tee" = "x"], [
- have_blogc_deps=no
], [
- have_blogc_deps=yes
have_tests=yes
TESTS="enabled"
])
- AS_IF([test "x$have_bgr_deps" = "xyes"],, [
- AS_IF([test "x$have_git_receiver" = "xyes"], [
- have_tests=no
- TESTS="disabled"
- AS_IF([test "x$enable_tests" = "xyes"], [
- AC_MSG_ERROR([tests requested for blogc-git-receiver but git and/or tar not found])
- ], [
- AC_MSG_WARN([git and/or tar not found, install it to run blogc-git-receiver tests])
- ])
- ])
- ])
])
AM_CONDITIONAL([BUILD_TESTS], [test "x$have_tests" = "xyes"])
AM_CONDITIONAL([USE_CMOCKA], [test "x$have_cmocka" = "xyes"])