summaryrefslogtreecommitdiffstats
path: root/tests/blogc-git-receiver/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2024-05-21 01:29:20 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2024-05-21 01:29:20 +0200
commitb54b8f5b25403cf3b9623804b2491ec78a8b913e (patch)
tree8100b69a2fd1e37d1eb400a33c92ec3c984f208b /tests/blogc-git-receiver/CMakeLists.txt
parent0bbc18869720ad042b668742ca48e5cb8a37491a (diff)
downloadblogc-b54b8f5b25403cf3b9623804b2491ec78a8b913e.tar.gz
blogc-b54b8f5b25403cf3b9623804b2491ec78a8b913e.tar.bz2
blogc-b54b8f5b25403cf3b9623804b2491ec78a8b913e.zip
build: replace autotools with cmake
this patch removes all the autoconf/automake/libtool build infrastructure and replaces it with cmake. notable default behavior changes: - man pages are not pre-built, and are not built by default, must be enabled with `-DBUILD_MANPAGES=ON`. removed features: - srpm packaging, to be reintroduced at some point. - deb packaging, now handled externally via rafaelmartins/deb.rgm.io more stuff must be missing, please report bugs!
Diffstat (limited to 'tests/blogc-git-receiver/CMakeLists.txt')
-rw-r--r--tests/blogc-git-receiver/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/blogc-git-receiver/CMakeLists.txt b/tests/blogc-git-receiver/CMakeLists.txt
new file mode 100644
index 0000000..c0e88a7
--- /dev/null
+++ b/tests/blogc-git-receiver/CMakeLists.txt
@@ -0,0 +1,19 @@
+# SPDX-FileCopyrightText: 2024 Rafael G. Martins <rafael@rafaelmartins.eng.br>
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT Git_FOUND)
+ message(FATAL_ERROR "blogc-git-receiver tests require Git.")
+endif()
+
+find_program(MAKE make gmake REQUIRED)
+find_program(TAR tar REQUIRED)
+
+blogc_executable_test(blogc_git_receiver pre_receive_parser)
+blogc_executable_test(blogc_git_receiver settings
+ WRAP
+ realpath
+)
+blogc_executable_test(blogc_git_receiver shell_command_parser)
+blogc_script_test(blogc_git_receiver post_receive)
+blogc_script_test(blogc_git_receiver pre_receive)
+blogc_script_test(blogc_git_receiver shell)