aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 75e68ea..0f5c5e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,6 +84,7 @@ if USE_CMOCKA
check_PROGRAMS += \
tests/check_error \
tests/check_loader \
+ tests/check_renderer \
tests/check_source_parser \
tests/check_template_parser \
tests/check_utils \
@@ -123,6 +124,23 @@ tests_check_loader_LDADD = \
libblogc.la \
$(NULL)
+tests_check_renderer_SOURCES = \
+ tests/check_renderer.c \
+ $(NULL)
+
+tests_check_renderer_CFLAGS = \
+ $(CMOCKA_CFLAGS) \
+ $(NULL)
+
+tests_check_renderer_LDFLAGS = \
+ -no-install \
+ $(NULL)
+
+tests_check_renderer_LDADD = \
+ $(CMOCKA_LIBS) \
+ libblogc.la \
+ $(NULL)
+
tests_check_source_parser_SOURCES = \
tests/check_source_parser.c \
$(NULL)