aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e42b6d..78b29e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -170,9 +170,11 @@ dist_man_MANS = \
if BUILD_GIT_RECEIVER
EXTRA_DIST += \
+ man/blogc-git-receiver.1.ronn \
$(NULL)
dist_man_MANS += \
+ blogc-git-receiver.1 \
$(NULL)
endif
@@ -198,6 +200,14 @@ blogc.1: man/blogc.1.ronn
--manual "$(PACKAGE_NAME) Manual" \
$(top_srcdir)/man/blogc.1.ronn > blogc.1
+blogc-git-receiver.1: man/blogc-git-receiver.1.ronn
+ $(AM_V_GEN)$(RONN) \
+ --roff \
+ --pipe \
+ --organization "Rafael G. Martins" \
+ --manual "$(PACKAGE_NAME) Manual" \
+ $(top_srcdir)/man/blogc-git-receiver.1.ronn > blogc-git-receiver.1
+
blogc-source.7: man/blogc-source.7.ronn
$(AM_V_GEN)$(RONN) \
--roff \
@@ -219,6 +229,9 @@ else
blogc.1:
$(AM_V_GEN)echo "error: ronn not found. failed to build man page: $@"; exit 1
+blogc-git-receiver.1:
+ $(AM_V_GEN)echo "error: ronn not found. failed to build man page: $@"; exit 1
+
blogc-source.7:
$(AM_V_GEN)echo "error: ronn not found. failed to build man page: $@"; exit 1