aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ce27e54..69a337b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,10 +136,12 @@ RUNSERVER="disabled"
AC_ARG_ENABLE([runserver], AS_HELP_STRING([--enable-runserver],
[build blogc-runserver tool]))
AS_IF([test "x$enable_runserver" = "xyes"], [
- AC_CHECK_HEADERS([signal.h stdarg.h fcntl.h unistd.h sys/stat.h sys/types.h],, [
+ AC_CHECK_HEADERS([signal.h limits.h fcntl.h unistd.h sys/stat.h sys/types.h sys/socket.h netinet/in.h arpa/inet.h],, [
AC_MSG_ERROR([blogc-runserver tool requested but required headers not found])
])
- PKG_CHECK_MODULES([LIBEVENT], [libevent >= 2.0])
+ AX_PTHREAD([], [
+ AC_MSG_ERROR([blogc-runserver tool requested but pthread is not supported])
+ ])
RUNSERVER="enabled"
have_runserver=yes
])