aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cd2bc89..277a479 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ AM_CONDITIONAL([USE_VALGRIND], [test "x$have_valgrind" = "xyes"])
VALGRIND="$ac_cv_path_valgrind"
AC_SUBST(VALGRIND)
+TESTS="disabled"
AC_ARG_ENABLE([tests], AS_HELP_STRING([--disable-tests],
[disable unit tests, ignoring presence of cmocka]))
AS_IF([test "x$enable_tests" != "xno"], [
@@ -43,7 +44,6 @@ AS_IF([test "x$enable_tests" != "xno"], [
TESTS="enabled"
have_cmocka=yes
], [
- TESTS="disabled"
have_cmocka=no
])
])