aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0fdbf6a..8b3b44e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,9 @@ AC_ARG_ENABLE([make-embedded], AS_HELP_STRING([--enable-make-embedded],
AC_ARG_ENABLE([make], AS_HELP_STRING([--enable-make],
[build blogc-make tool]))
AS_IF([test "x$enable_make" = "xyes" -o "x$enable_make_embedded" = "xyes"], [
+ AC_CHECK_HEADERS([dirent.h fcntl.h libgen.h sys/stat.h sys/wait.h time.h unistd.h],, [
+ AC_MSG_ERROR([blogc-make tool requested but required headers not found])
+ ])
AX_PTHREAD([], [
AC_MSG_ERROR([blogc-make tool requested but pthread is not supported])
])