aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2dfc43e..6e6b490 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,6 +106,9 @@ AS_IF([test "x$enable_make" = "xyes" -o "x$enable_make_embedded" = "xyes"], [
AC_CHECK_HEADERS([dirent.h fcntl.h libgen.h sys/stat.h sys/wait.h time.h unistd.h],, [
AC_MSG_ERROR([blogc-make tool requested but required headers not found])
])
+ AX_PTHREAD([], [
+ AC_MSG_ERROR([blogc-make tool requested but pthread is not supported])
+ ])
have_make_lib=yes
AS_IF([test "x$enable_make_embedded" = "xyes"], [
MAKE_="enabled (embedded)"