aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9e6d7eb..35cbba9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,7 @@ AS_IF([test "x$enable_runserver" = "xyes"], [
AC_MSG_ERROR([blogc-runserver tool requested but pthread is not supported])
])
RUNSERVER="enabled"
+ have_threads=yes
have_runserver=yes
])
AM_CONDITIONAL([BUILD_RUNSERVER], [test "x$have_runserver" = "xyes"])
@@ -220,6 +221,8 @@ AM_CONDITIONAL([USE_BGR_DEPS], [test "x$have_bgr_deps" = "xyes"])
BASH="$ac_cv_path_bash"
AC_SUBST(BASH)
+AM_CONDITIONAL([USE_THREADS], [test "x$have_threads" = "xyes"])
+
AC_CHECK_HEADERS([sys/stat.h time.h])
LT_LIB_M