summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..cc5af5d
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,22 @@
+# SPDX-FileCopyrightText: 2024 Rafael G. Martins <rafael@rafaelmartins.eng.br>
+# SPDX-License-Identifier: BSD-3-Clause
+
+add_subdirectory(common)
+
+option(BUILD_BLOGC_MAKE "Build blogc-make binary." OFF)
+option(BUILD_BLOGC_MAKE_EMBEDDED "Build blogc-make embedded into blogc binary." OFF)
+if(BUILD_BLOGC_MAKE OR BUILD_BLOGC_MAKE_EMBEDDED)
+ add_subdirectory(blogc-make)
+endif()
+
+option(BUILD_BLOGC_RUNSERVER "Build blogc-runserver binary." OFF)
+if(BUILD_BLOGC_RUNSERVER)
+ add_subdirectory(blogc-runserver)
+endif()
+
+option(BUILD_BLOGC_GIT_RECEIVER "Build blogc-git-receiver binary." OFF)
+if(BUILD_BLOGC_GIT_RECEIVER)
+ add_subdirectory(blogc-git-receiver)
+endif()
+
+add_subdirectory(blogc)