summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
new file mode 100644
index 0000000..1619f95
--- /dev/null
+++ b/src/common/CMakeLists.txt
@@ -0,0 +1,21 @@
+# SPDX-FileCopyrightText: 2024 Rafael G. Martins <rafael@rafaelmartins.eng.br>
+# SPDX-License-Identifier: BSD-3-Clause
+
+add_library(libblogc_common STATIC
+ compat.c
+ compat.h
+ config-parser.c
+ config-parser.h
+ error.c
+ error.h
+ file.c
+ file.h
+ sort.c
+ sort.h
+ stdin.c
+ stdin.h
+ utf8.c
+ utf8.h
+ utils.c
+ utils.h
+)