summaryrefslogtreecommitdiffstats
path: root/tests/blogc-make/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/blogc-make/CMakeLists.txt')
-rw-r--r--tests/blogc-make/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/blogc-make/CMakeLists.txt b/tests/blogc-make/CMakeLists.txt
new file mode 100644
index 0000000..9990eae
--- /dev/null
+++ b/tests/blogc-make/CMakeLists.txt
@@ -0,0 +1,19 @@
+# SPDX-FileCopyrightText: 2024 Rafael G. Martins <rafael@rafaelmartins.eng.br>
+# SPDX-License-Identifier: BSD-3-Clause
+
+blogc_executable_test(blogc_make atom)
+blogc_executable_test(blogc_make exec
+ WRAP
+ access
+)
+blogc_executable_test(blogc_make rules)
+blogc_executable_test(blogc_make settings)
+blogc_executable_test(blogc_make utils)
+
+if(BUILD_BLOGC_MAKE_EMBEDDED)
+ set(_BLOGC_MAKE "${CMAKE_BINARY_DIR}/src/blogc/blogc -m")
+else()
+ set(_BLOGC_MAKE "${CMAKE_BINARY_DIR}/src/blogc-make/blogc-make")
+endif()
+
+blogc_script_test(blogc_make blogc_make)