aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-11-02 03:58:09 -0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-11-02 03:58:09 -0200
commit1faa52052624e7c03256df0c63c43f5d40ddb57a (patch)
treeff53b56d31231f9f05fd3ff9f518f7f90f90bea0 /Makefile.am
parent5b869700957af87f672f4be6336a8f587450ec14 (diff)
downloadblogc-1faa52052624e7c03256df0c63c43f5d40ddb57a.tar.gz
blogc-1faa52052624e7c03256df0c63c43f5d40ddb57a.tar.bz2
blogc-1faa52052624e7c03256df0c63c43f5d40ddb57a.zip
content-parser: added basic rst-like directives support
this patch adds support to something similar to reStructuredText directives [1]. the directive loader isn't implemented yet. also, the current implementation is stricter and differs a lot from the reStructuredText spec. documentation pending. this patch also fixes a few old parser bugs. [1] http://docutils.sourceforge.net/docs/ref/rst/directives.html
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4a28b8b..4e79863 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,7 @@ MAINTAINERCLEANFILES = \
noinst_HEADERS = \
src/content-parser.h \
src/datetime-parser.h \
+ src/directives.h \
src/file.h \
src/error.h \
src/loader.h \
@@ -53,6 +54,7 @@ check_PROGRAMS = \
libblogc_la_SOURCES = \
src/content-parser.c \
src/datetime-parser.c \
+ src/directives.c \
src/file.c \
src/error.c \
src/loader.c \
@@ -198,6 +200,7 @@ tests_check_content_parser_CFLAGS = \
tests_check_content_parser_LDFLAGS = \
-no-install \
+ -Wl,--wrap=blogc_directive_loader \
$(NULL)
tests_check_content_parser_LDADD = \