aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-08-20 20:45:42 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-08-20 20:45:42 -0300
commit54689c1192ebfdb65e5ab9a0b4ce3b2c04df4b10 (patch)
tree5a04467cbe2f3d7c6c445234c7df141fb6c72247 /Makefile.am
parent3cab05897319c1786d80d4a99ea35849f4bf2ae6 (diff)
downloadblogc-54689c1192ebfdb65e5ab9a0b4ce3b2c04df4b10.tar.gz
blogc-54689c1192ebfdb65e5ab9a0b4ce3b2c04df4b10.tar.bz2
blogc-54689c1192ebfdb65e5ab9a0b4ce3b2c04df4b10.zip
build: raise error if trying to rebuild man pages without ronn
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index aa23d15..3168c6e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -123,6 +123,14 @@ blogc%.7: man/blogc%.7.ronn
--manual "$(PACKAGE_NAME) Manual" \
$< > $@
+else
+
+blogc.1:
+ $(AM_V_GEN)echo "error: ronn not found. failed to build man page: $@"; exit 1
+
+blogc%.7:
+ $(AM_V_GEN)echo "error: ronn not found. failed to build man page: $@"; exit 1
+
endif