aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-10-24 18:47:41 -0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-10-24 18:47:41 -0200
commit7127defbaa3701fc3444feb3233401e2829fc1b6 (patch)
tree452d47a9ee63dcdbc2ba4c0bee9b562af483233f /Makefile.am
parent3a5ea19f35e4228cd782d69f21f52656c1e9a1b8 (diff)
downloadblogc-7127defbaa3701fc3444feb3233401e2829fc1b6.tar.gz
blogc-7127defbaa3701fc3444feb3233401e2829fc1b6.tar.bz2
blogc-7127defbaa3701fc3444feb3233401e2829fc1b6.zip
datetime-parser: initial implementation. not used yet
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e64eea9..4a28b8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,7 @@ MAINTAINERCLEANFILES = \
noinst_HEADERS = \
src/content-parser.h \
+ src/datetime-parser.h \
src/file.h \
src/error.h \
src/loader.h \
@@ -51,6 +52,7 @@ check_PROGRAMS = \
libblogc_la_SOURCES = \
src/content-parser.c \
+ src/datetime-parser.c \
src/file.c \
src/error.c \
src/loader.c \
@@ -141,6 +143,7 @@ if USE_CMOCKA
check_PROGRAMS += \
tests/check_content_parser \
+ tests/check_datetime_parser \
tests/check_error \
tests/check_loader \
tests/check_renderer \
@@ -202,6 +205,23 @@ tests_check_content_parser_LDADD = \
libblogc.la \
$(NULL)
+tests_check_datetime_parser_SOURCES = \
+ tests/check_datetime_parser.c \
+ $(NULL)
+
+tests_check_datetime_parser_CFLAGS = \
+ $(CMOCKA_CFLAGS) \
+ $(NULL)
+
+tests_check_datetime_parser_LDFLAGS = \
+ -no-install \
+ $(NULL)
+
+tests_check_datetime_parser_LDADD = \
+ $(CMOCKA_LIBS) \
+ libblogc.la \
+ $(NULL)
+
tests_check_renderer_SOURCES = \
tests/check_renderer.c \
$(NULL)