aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-23 01:37:57 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-23 01:37:57 -0300
commit8d2b09e474dd0e3fdd8d3c03a0b520a398a9e82a (patch)
tree1e2e93d6b93a1d416fb80665612f8c145564e676 /Makefile.am
parent280f6199a03ebc17fc2dc515079a6c09b1bf13f9 (diff)
downloadblogc-8d2b09e474dd0e3fdd8d3c03a0b520a398a9e82a.tar.gz
blogc-8d2b09e474dd0e3fdd8d3c03a0b520a398a9e82a.tar.bz2
blogc-8d2b09e474dd0e3fdd8d3c03a0b520a398a9e82a.zip
added renderer tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 75e68ea..0f5c5e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,6 +84,7 @@ if USE_CMOCKA
check_PROGRAMS += \
tests/check_error \
tests/check_loader \
+ tests/check_renderer \
tests/check_source_parser \
tests/check_template_parser \
tests/check_utils \
@@ -123,6 +124,23 @@ tests_check_loader_LDADD = \
libblogc.la \
$(NULL)
+tests_check_renderer_SOURCES = \
+ tests/check_renderer.c \
+ $(NULL)
+
+tests_check_renderer_CFLAGS = \
+ $(CMOCKA_CFLAGS) \
+ $(NULL)
+
+tests_check_renderer_LDFLAGS = \
+ -no-install \
+ $(NULL)
+
+tests_check_renderer_LDADD = \
+ $(CMOCKA_LIBS) \
+ libblogc.la \
+ $(NULL)
+
tests_check_source_parser_SOURCES = \
tests/check_source_parser.c \
$(NULL)