aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 19:09:46 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2015-04-19 19:09:46 -0300
commit01e9b5c0191762b75175f6eabfb9915f9899fc15 (patch)
treec1db09f8681e30f46b6cc9cb4661d6eed162603e /configure.ac
parent329ef39c0fe382498dde48b5822b041a3804f618 (diff)
downloadblogc-01e9b5c0191762b75175f6eabfb9915f9899fc15.tar.gz
blogc-01e9b5c0191762b75175f6eabfb9915f9899fc15.tar.bz2
blogc-01e9b5c0191762b75175f6eabfb9915f9899fc15.zip
build: replace --enable-cmocka with --enable-tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 5736a33..cd2bc89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,21 +35,21 @@ AM_CONDITIONAL([USE_VALGRIND], [test "x$have_valgrind" = "xyes"])
VALGRIND="$ac_cv_path_valgrind"
AC_SUBST(VALGRIND)
-AC_ARG_ENABLE([cmocka], AS_HELP_STRING([--disable-cmocka],
- [ignore presence of cmocka. this will disable unit tests]))
-AS_IF([test "x$enable_cmocka" != "xno"], [
+AC_ARG_ENABLE([tests], AS_HELP_STRING([--disable-tests],
+ [disable unit tests, ignoring presence of cmocka]))
+AS_IF([test "x$enable_tests" != "xno"], [
PKG_PROG_PKG_CONFIG
PKG_CHECK_MODULES([CMOCKA], [cmocka], [
- CMOCKA="enabled"
+ TESTS="enabled"
have_cmocka=yes
], [
- CMOCKA="disabled"
+ TESTS="disabled"
have_cmocka=no
])
])
AS_IF([test "x$have_cmocka" = "xyes"], , [
- AS_IF([test "x$enable_cmocka" = "xyes"], [
- AC_MSG_ERROR([cmocka requested but not found])
+ AS_IF([test "x$enable_tests" = "xyes"], [
+ AC_MSG_ERROR([unit tests requested but cmocka not found])
])
])
AM_CONDITIONAL([USE_CMOCKA], [test "x$have_cmocka" = "xyes"])
@@ -70,7 +70,7 @@ AS_ECHO("
cflags: ${CFLAGS}
ldflags: ${LDFLAGS}
- cmocka: ${CMOCKA}
+ tests: ${TESTS}
valgrind: ${VALGRIND}
")