aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2017-02-11 18:51:12 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2017-02-11 18:51:12 +0100
commitcbeba5720d1b98cd7db013038b741b1a6ac9e48c (patch)
tree01c84556d6a799847e287c4f1eb73cabc3d06d38 /configure.ac
parentee6b177bc1cbc55472c85497e5043163d89ff814 (diff)
downloadblogc-cbeba5720d1b98cd7db013038b741b1a6ac9e48c.tar.gz
blogc-cbeba5720d1b98cd7db013038b741b1a6ac9e48c.tar.bz2
blogc-cbeba5720d1b98cd7db013038b741b1a6ac9e48c.zip
Revert "make: do not require pthreads"
This reverts commit dd0ff8219b749f89ae66261830d10f1c27940b19.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2dfc43e..6e6b490 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,6 +106,9 @@ AS_IF([test "x$enable_make" = "xyes" -o "x$enable_make_embedded" = "xyes"], [
AC_CHECK_HEADERS([dirent.h fcntl.h libgen.h sys/stat.h sys/wait.h time.h unistd.h],, [
AC_MSG_ERROR([blogc-make tool requested but required headers not found])
])
+ AX_PTHREAD([], [
+ AC_MSG_ERROR([blogc-make tool requested but pthread is not supported])
+ ])
have_make_lib=yes
AS_IF([test "x$enable_make_embedded" = "xyes"], [
MAKE_="enabled (embedded)"