aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2020-12-31 05:19:23 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2020-12-31 05:19:23 +0100
commitb825738de2f33ffd893f4d1fd2c777d1a7436d32 (patch)
treef08b008e44efd4f6605e5ba8ee6badc2d12bc568 /debian/rules
parent87092ed2493d3ac01b57100f15f9cfa1c4acdec7 (diff)
downloadblogc-b825738de2f33ffd893f4d1fd2c777d1a7436d32.tar.gz
blogc-b825738de2f33ffd893f4d1fd2c777d1a7436d32.tar.bz2
blogc-b825738de2f33ffd893f4d1fd2c777d1a7436d32.zip
added debian packaging
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ca63b74
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --disable-ronn \
+ --enable-git-receiver \
+ --enable-make \
+ --enable-runserver