aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2021-03-29 00:03:14 +0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2021-03-29 00:47:41 +0200
commit12efeb634552cc993f9bacb8174b34214f777283 (patch)
treeeeee97e1fa5c0383a4d01ed89c0a2a0dffd3dc76 /Makefile.am
parentd2e1bb55bcc38d6f118654fa38d6396e2f980721 (diff)
downloadblogc-12efeb634552cc993f9bacb8174b34214f777283.tar.gz
blogc-12efeb634552cc993f9bacb8174b34214f777283.tar.bz2
blogc-12efeb634552cc993f9bacb8174b34214f777283.zip
blogc: sysinfo: get fqdn if available
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9471577..571cb41 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -558,6 +558,12 @@ tests_blogc_check_sysinfo_LDFLAGS = \
-Wl,--wrap=getenv \
$(NULL)
+if HAVE_NETDB_H
+tests_blogc_check_sysinfo_LDFLAGS += \
+ -Wl,--wrap=gethostbyname \
+ $(NULL)
+endif
+
if HAVE_UNISTD_H
tests_blogc_check_sysinfo_LDFLAGS += \
-Wl,--wrap=gethostname \