aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9471577..571cb41 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -558,6 +558,12 @@ tests_blogc_check_sysinfo_LDFLAGS = \
-Wl,--wrap=getenv \
$(NULL)
+if HAVE_NETDB_H
+tests_blogc_check_sysinfo_LDFLAGS += \
+ -Wl,--wrap=gethostbyname \
+ $(NULL)
+endif
+
if HAVE_UNISTD_H
tests_blogc_check_sysinfo_LDFLAGS += \
-Wl,--wrap=gethostname \