aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2018-12-21 03:55:00 +0100
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2018-12-21 03:55:00 +0100
commiteac073d479dfbe5ecf9c5fc7180f7b29da6d1298 (patch)
tree14db2b6f4c921e7c462b20d59a61fc2cf5446625 /configure.ac
parent62919eee3ef5fbad678034c21948abed523fa47e (diff)
downloadblogc-eac073d479dfbe5ecf9c5fc7180f7b29da6d1298.tar.gz
blogc-eac073d479dfbe5ecf9c5fc7180f7b29da6d1298.tar.bz2
blogc-eac073d479dfbe5ecf9c5fc7180f7b29da6d1298.zip
wip
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6ed9e3d..fc6c2ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,12 @@ PKG_PROG_PKG_CONFIG
AC_PROG_SED
+have_pthread=no
+AX_PTHREAD([
+ have_pthread=yes
+])
+AM_CONDITIONAL([BUILD_PTHREAD], [test "x$have_pthread" = "xyes"])
+
RPM_VERSION=`echo ${PACKAGE_VERSION} | sed "s/-/./g"`
AC_SUBST(RPM_VERSION)